Announcement

Collapse
No announcement yet.

Left turn signals stuck on

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Left turn signals stuck on

    After falling on its left side my FZ1 Left turn signals are stuck on solid without blinking. Right side works as they should.

    Where is the relay located so I can check it out? Also open to other ideas for fixes.

    Thanks in advance
    "Zygee" Zack Green

  • #2
    It's back by the battery. Does she start up okay now?
    Why are we here? Because we're here....Roll the bones

    Comment


    • #3
      Any chance the turn signal bulb failed and your seeing the running light?

      Comment


      • #4
        Yes the bike starts up and rides good which is definitely a plus.

        Come to think of it there could be an issue with the running light.

        The left turn signal lights are on constantly. If I flick the knob left they both blink about 4 times weakly and then stay solid.

        But the right side only has lights when I flick the knob for the right turn signal lights to blink. Otherwise the right front and right rear are just dark.

        In any case at least the rears only have one bulb. I haven't disassembled the front to see if there's a second one in there
        "Zygee" Zack Green

        Comment


        • #5
          So I found the relay immediately behind the battery. Unplugged it and all the lights stay the same except now neither side's turn signals will flash when I try to make them (which makes sense that they wouldn't flash since the relay is off).

          Still not sure what the fix is gonna be

          "Zygee" Zack Green

          Comment


          • #6
            Maybe take the switch apart? Sounds like possibly a ground issue?
            Why are we here? Because we're here....Roll the bones

            Comment

            Working...
            X